http://acm.hdu.edu.cn/showproblem.php?pid=1711
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. Input The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. Sample Input 2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1 Sample Output 6 -1 题目大意:输出首次匹配位置
#include<cstdio>
#include<cstring>
using namespace std;
int T,n,m,ans;
int a[1000001],b[10001],f[10001];
void getnext()
{
memset(f,0,sizeof(f));
for(int i=1;i<m;i++)
{
int j=f[i];
while(j&&b[i]!=b[j]) j=f[j];
f[i+1]= b[i]==b[j] ? j+1 : 0;
}
}
void getans()
{
ans=0;int j=0;
for(int i=0;i<n;i++)
{
while(j&&a[i]!=b[j]) j=f[j];
if(a[i]==b[j]) j++;
if(j==m) {printf("%d\n",i-j+2); return; }
}
printf("-1\n");
}
int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++) scanf("%d",&a[i]);
for(int j=0;j<m;j++) scanf("%d",&b[j]);
getnext();
getans();
}
}
作者:xxy 本文版权归作者所有,转载请用链接,请勿原文转载,Thanks♪(・ω・)ノ。