Can you solve this equation?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10943 Accepted Submission(s): 5046
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2 100 -4
Sample Output
1.6152 No solution!
Author
Redow
题目分析:精度比较恶心的二分,只要不超时,精度尽量开小就对了,涨姿势了
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#define eps 1e-12
#define EPS 1e-9
using namespace std;
double f ( double x )
{
return 8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6.0;
}
bool check ( double x , double n )
{
if ( f(x)+eps < n ) return true;
}
bool equal ( double a , double b )
{
if ( fabs ( a -b ) < eps ) return true;
else return false;
}
double search ( double n )
{
double left = 0.0 , right = 100.0 , mid;
while ( !equal ( left , right ))
{
mid = (left + right) / 2.0;
if ( check ( mid , n ) ) left = mid;
else right = mid;
}
return mid;
}
int t;
double n;
int main ( )
{
scanf ( "%d" , &t );
while ( t-- )
{
scanf ( "%lf" , &n );
if ( n < f(0) || n > f(100 ) )
{
puts ( "No solution!" );
continue;
}
double ans = search ( n );
printf ("%.4lf\n" , ans );
}
}