Reduced ID Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 9152   Accepted: 3674

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 10 6-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2 1 124866 3 124866 111111 987651

Sample Output

1 8

Source

Northwestern Europe 2005
题目分析:
枚举当前的模,然后枚举每一个数,取模后的数进行标记,证明当前的模不可行,否则可行
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#define MAX 1000007
#define N 307

using namespace std;

int t,n,cnt;
int a[N];
bool mark[MAX];

int main ( )
{
    scanf ( "%d" , &t );
    while ( t-- )
    {
        scanf ( "%d" , &n );
        for ( int i = 1 ; i <= n ; i++ )
           scanf ( "%d" , &a[i] );
        int ans = 1;
        while ( 1 )
        {
            bool flag = true;
            for ( int i = 0 ; i <= ans ; i++ )
                mark[i] = false;
            for ( int i = 1 ; i <= n ; i++ )
                if ( mark[a[i]%ans] )
                {
                    flag = false;
                    break;
                }
                else mark[a[i]%ans] = true;
            if ( flag ) break;
            ans++;
        }
        printf ( "%d\n" , ans );
    }
}