Cow Bowling


http://poj.org/problem?id=3176



Time Limit:  1000MS


Memory Limit: 65536K




Description



The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

7 3 8 8 1 0 2 7 4 4 4 5 2 6 5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 



Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.



Input



Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.



Output



Line 1: The largest sum achievable using the traversal rules



Sample Input



5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5



Sample Output



30



Hint



Explanation of the sample: 

7 * 3 8 * 8 1 0 * 2 7 4 4 * 4 5 2 6 5



Source



USACO 2005 December Bronze




记忆化搜索:

/*47ms,1356KB*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 355;

int a[maxn][maxn], dp[maxn][maxn], n;

int f(int i, int j)
{
	if (dp[i][j] >= 0) return dp[i][j];
	if (i == n - 1) return dp[i][j] = a[i][j];
	return dp[i][j] = a[i][j] + max(f(i + 1, j), f(i + 1, j + 1));
}

int main()
{
	int i, j;
	scanf("%d", &n);
	for (i = 0; i < n; ++i)
		for (j = 0; j <= i; ++j)
			scanf("%d", &a[i][j]);
	memset(dp, -1, sizeof(dp));
	printf("%d", f(0, 0));
	return 0;
}


递推:

/*16ms,868KB*/

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 355;

int a[maxn][maxn];

int main()
{
	int n, i, j;
	scanf("%d", &n);
	for (i = 0; i < n; ++i)
		for (j = 0; j <= i; ++j)
			scanf("%d", &a[i][j]);
	for (i = n - 2; i >= 0; --i)
		for (j = 0; j <= i; ++j)
			a[i][j] += max(a[i + 1][j], a[i + 1][j + 1]);
	printf("%d", a[0][0]);
	return 0;
}