Number Sequence
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 50 Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3 1 2 10 0 0 0
Sample Output
2 5
解思:f(n)=(a*f(n-1)+b*f(n-2))%7.共有7种可能取值0~6.因为a和b都是固定的所以f(n-1)和f(n-2)最多有7*7种组合。故定义一个数组,可储存52位就够了,从第3个数开始循环寻找,知道出现和第一个和第二个一样的f(n),f(n-1)便结束循环。此时便得n以内几个数一循环。具体做法详代码。
代码:
#include <iostream>
#include <cstring>using namespace std;
int f[1000001];
int main()
{
int a,b,n; while(cin>>a>>b>>n)
{
if(a==0&&b==0&&n==0)
break;
f[1]=1;
f[2]=1;
int xh=0;
int i;
for(i=3;i<=1001;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
if(f[i]==1&&f[i-1]==1)
{
break;
}
}
xh=i-2;
n=n%xh;
if(n==0)n=xh;
cout<<f[n]<<endl;
}
return 0;
}