Description
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence
1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...
shows the first 10 ugly numbers. By convention, 1 is included.
Given the integer n,write a program to find and print the n'th ugly number.
Input
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.
Output
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.
Sample Input
1 2 9 0
Sample Output
1 2 10 算法思想:满足条件的数一定是2或3或5的倍数(包括1)。 设置三个变量m2,m3,m5,表示下一个满足条件的数是2*a[m2],3*a[m3]和5*a[m5]这三个数中的最小者。 满足条件的 m 值加1.下次从新的 m 值乘以相应的倍数。如要求a[8]时,m2 = 4,m3 = 3, m5 = 1, 由于2 * a[4] = 10 及5 * a[1] = 10 小于 3 * a[3] = 12,这时可得a[8] = 10,同时 m2 = m2 + 1 = 5, m5 = m5 + 1 = 2.
代码:
#include <iostream>
using namespace std;
int main()
{
int n,p,i,m2,m3,m5;
int a[1505],t;
while(cin>>n&&n!=0)
{
m2=0;
m3=0;
m5=0;
a[0]=1;
for(i=1;i<n;i++)
{
if(2*a[m2]>3*a[m3])
t=a[m3]*3;
else
t=a[m2]*2;
if(t>5*a[m5])
t=a[m5]*5;
if(t==2*a[m2]) m2++;
if(t==3*a[m3]) m3++;
if(t==5*a[m5]) m5++;
a[i]=t;
}
cout<<a[n-1]<<endl;
}
return 0;
}