ZOJ Problem Set - 3819
Average Score
Time Limit: 2 Seconds
Memory Limit: 65536 KB
Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.
After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:
"Too bad! You made me so disappointed."
"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."
Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].
Input
There are multiple test cases. The first line of input contains an integer T
The first line contains two integers N (2 <= N <= 50) and M (1 <= M
The next line contains N - 1 integers A1, A2, .., AN-1
The last line contains M integers B1, B2, .., BM
Output
For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.
It is guaranteed that the solution always exists.
Sample Input
2 4 3 5 5 5 4 4 3 6 5 5 5 4 5 3 1 3 2 2 1
Sample Output
4 4 2 4
题目大意:有两个班A班和B班,Bob是A班的,给出A班中出Bob之外的所有学生成绩和B班里的所有学生的成绩,Bob的成绩能使A班的平均成绩下降,使B 班的平均成绩提高,求Bob的成绩满足上诉条件是取得的最小值和最大值。
代码:
#include <iostream>
using namespace std;
int main()
{
int a,b;
int sum1,sum2;
int t;
cin>>t;
while(t--)
{
int max1,min1;
int n,m;
cin>>n>>m;
int i,j;
sum1=0;
sum2=0;
for(i=0;i<n-1;i++)
{
cin>>a;
sum1+=a;
}
for(j=0;j<m;j++)
{
cin>>b;
sum2+=b;
}
double aver1;
double aver2;
aver1=sum1/(n-1.0);
aver2=sum2/(m*1.0);
if(int(aver1)==aver1)
max1=int(aver1)-1;
else
max1=int(aver1);
min1=int(aver2)+1;
cout<<min1<<' '<<max1<<endl;
}
return 0;
}