1 h0145. 会议安排

        学校的礼堂每天都会有许多活动,有时间这些活动的计划时间会发生冲突,需要选择出一些活动进行举办。小刘的工作就是安排学校礼堂的活动,每个时间最多安排一个活动。现在小刘有一些活动计划的时间表,他想尽可能的安排更多的活动,请问他该如何安排。

输入格式:

第一行是一个整型数m(m<100)表示共有m组测试数据。
每组测试数据的第一行是一个整数n(1<n<10000)表示该测试数据共有n个活动。
随后的n行,每行有两个正整数Bi,Ei(0<=Bi,Ei<10000),分别表示第i个活动的起始与结束时间(Bi<=Ei)

输出格式:

对于每一组输入,输出最多能够安排的活动数量。
每组的输出占一行

输入样例:

在这里给出一组输入。例如:

2
2
1 10
10 11
3
1 10
9 11
11 20

输出样例:

在这里给出相应的输出。例如:

2
2

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include <iostream>
#include <algorithm>
#include <cstdio>

using namespace std;

typedef struct Session
{
    int start;
    int end;
} Session;

bool cmp (const Session& a, const Session& b);

int main()
{
    int m;
    int count; //计算有多少个会议
    cin >> m;


    for(int i = 0; i < m; i++)
    {
        count = 0;
        int n;
        cin >> n;
        Session s[n];
        Session f[n]; //存放最优解
        for(int j = 0; j < n; j++)
        {
            cin >> s[j].start >> s[j].end;
        }
        //将结构体按照结束时间排序
        sort(s, s+n, cmp);
        f[count++] = s[0]; //第一个先存进去
        for(int j = 1; j < n; j++)
        {
            //当最优解的结尾小于后一个的开始,说明可以选择后一个
            if(f[count-1].end <= s[j].start)
            {
                f[count++] = s[j];
            }
        }
        cout << count << endl;
    }

    return 0;
}

bool cmp (const Session& a, const Session& b)
{
    return a.end < b.end;
}

 

2 选课(贪心)

小明是个好学的程序猿,他想在一天内尽可能多的选择课程进行学习。在下列课程中,他能选择的最多课程是几门?

输入格式:

第一行为一个整数n,表示课程总数。接下来每行为x,y,z表示课程名,开始时间,结束时间。

输出格式:

输出一个整数,表示小明最多可选的课程数。

输入样例:

5
Art  9 10
English 9.3 10.3
Math 10 11
Computer 10.3  11.3
Music 11 12

输出样例:

在这里给出相应的输出。例如:

3

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include <iostream>
#include <algorithm>
#include <cstdio>

using namespace std;



typedef struct Session
{
    string name;
    float start;
    float end;
} Session;

bool cmp (const Session& a, const Session& b);
void show(Session s[], int n);
int main()
{
    int n;
    int count = 0; //计算有多少个会议
    cin >> n;
    Session s[n];
    Session f[n]; //存放最优解

    for(int j = 0; j < n; j++)
    {
        cin >> s[j].name >> s[j].start >> s[j].end;
    }
    //将结构体按照结束时间排序
    sort(s, s+n, cmp);
    f[count++] = s[0]; //第一个先存进去
    for(int j = 1; j < n; j++)
    {
        //当最优解的结尾小于后一个的开始,说明可以选择后一个
        if(f[count-1].end <= s[j].start)
        {
            f[count++] = s[j];
        }
    }
    cout << count << endl;
    //cout <<"----------------"<< endl;
    //show(f, count);

    return 0;
}

bool cmp (const Session& a, const Session& b)
{
    return a.end < b.end;
}
void show(Session s[], int n)
{
    for(int i = 0; i < n; i++)
    {
        cout << s[i].name << ' ' << s[i].start << ' ' << s[i].end << endl;

    }
}