uva 537 Artificial Intelligence?
Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!
So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".
However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."
OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)
Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I
Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.
Input
The first line of the input file will contain the number of test cases.
Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number.
Directly before the unit (A, V or W) one of the prefixes m (milli), k (kilo) and M
DataField ::= Concept '=' RealNumber [Prefix] Unit Concept ::= 'P' | 'U' | 'I' Prefix ::= 'm' | 'k' | 'M' Unit ::= 'W' | 'V' | 'A'
Additional assertions:
- The equal sign (`=') will never occur in an other context than within a data field.
- There is no whitespace (tabs,blanks) inside a data field.
- Either P and U, P and I, or U and I
Output
For each test case, print three lines:
- a line saying ``Problem #k" where k is the number of the test case
- a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
- a blank line
Sample Input
3 If the voltage is U=200V and the current is I=4.5A, which power is generated? A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please. bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?
Sample Output
Problem #1 P=900.00W Problem #2 I=0.45A Problem #3 U=1250000.00V
题目大意:在一个字符串中P、U、I中任意两个值,求另外一个值。
解题思路:水题,匹配赋值,得解(注意数值后面的前缀),注意!!值可能为负!!
<span style="color:#000000;">#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main() {
int cnt;
int cnt4 = 1;
scanf("%d\n", &cnt);
while (cnt--) {
int cnt2 = 0, cnt3;
char s[200];
float value[3];
float Prefix[3] = {0.001, 1000, 1000000};
char Concept[3] = {'P', 'U', 'I'};
char Unit[3] = {'W', 'V', 'A'};
char temp[10];
memset(value, 0, sizeof(value));
memset(s, 0, sizeof(s));
gets(s);
int len = strlen(s);
for (int i = 0; i < len; i++) {
if (s[i] == 'U' && s[i+1] == '=') {
memset(temp, 0, sizeof(temp));
cnt2++;
i++;
cnt3 = 0;
while (i++) {
if ((s[i] >= '0' && s[i] <= '9') || s[i] == '.' || s[i] == '-') { //考虑负号情况
temp[cnt3++] = s[i];
}
else break;
}
value[1] = atof(temp); //atof函数,将字符类型转换为浮点类型
if (s[i] == 'm') value[1] /= 1000; //单位的判断
else if (s[i] == 'k') value[1] *= 1000;
else if (s[i] == 'M') value[1] *= 1000000;
}
else if (s[i] == 'P' && s[i+1] == '=') {
memset(temp, 0, sizeof(temp));
cnt2++;
i++;
cnt3 = 0;
while (i++) {
if ((s[i] >= '0' && s[i] <= '9') || s[i] == '.' || s[i] == '-'){
temp[cnt3++] = s[i];
}
else break;
}
value[0] = atof(temp);
if (s[i] == 'm') value[0] /= 1000;
else if (s[i] == 'k') value[0] *= 1000;
else if (s[i] == 'M') value[0] *= 1000000;
}
else if (s[i] == 'I' && s[i+1] == '=') {
memset(temp, 0, sizeof(temp));
cnt2++;
i++;
cnt3 = 0;
while (i++) {
if ((s[i] >= '0' && s[i] <= '9') || s[i] == '.' || s[i] == '-') {
temp[cnt3++] = s[i];
}
else break;
}
value[2] = atof(temp);
if (s[i] == 'm') value[2] /= 1000;
else if (s[i] == 'k') value[2] *= 1000;
else if (s[i] == 'M') value[2] *= 1000000;
}
if (cnt2 == 2) {
printf("Problem #%d\n", cnt4++);
if (value[0] != 0 && value[1] != 0) { //三种情况(已知PV求I,已知PI求V,已知UI求P)
printf("%c=%.2f%c\n\n", Concept[2], value[0] / value[1], Unit[2]);
break;
}
if (value[0] != 0 && value[2] != 0) {
printf("%c=%.2f%c\n\n", Concept[1], value[0] / value[2], Unit[1]);
break;
}
if (value[1] != 0 && value[2] != 0) {
printf("%c=%.2f%c\n\n", Concept[0], value[1] * value[2], Unit[0]);
break;
}
}
}
}
return 0;
}</span>