zhx's contest



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)




Problem Description


n problems.
zhx thinks the ith problem's difficulty is i. He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1..ai are monotone decreasing or monotone increasing.
2: ai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p.


 



Input


1000). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. ( 1≤n,p≤1018)


 



Output


For each test case, output a single line indicating the answer.


 



Sample Input


2 233 3 5


 



Sample Output


Hint

In the first case, both sequence {1, 2} and {2, 1} are legal.

In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1


 


思路:首先是全部递减或全部递增各一种;另外就是满足上列两个条件的情况了,要想满足条件(1)那就只能把最大的n放在i位置,共有C(1,n-1)+C(2,n-1)+。。。+C(n-2,n-1)即2^(n-1)-2;条件(2)与(1)相同,所以共有(2^(n-1)-2)*2+2=2^n-2.


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define LL long long 
using namespace std;

LL n, p;

LL multi(LL a, LL b) {	//快速乘法,其实和快速幂差不多 
    LL ret = 0;
    while(b) {
        if(b & 1) ret = (ret + a) % p;
        a = (a + a) % p;
        b >>= 1;
    }
    return ret;
}

LL powmod(LL a, LL b) {	//快速幂 
    LL ret = 1;
    while(b) {
        if(b & 1) ret = multi(ret, a) % p;
        a = multi(a, a) % p;
        b >>= 1;
    }
    return ret;
}


int main() {
	while(cin >> n >> p) {
		if(p == 1) {
			cout << 0 << endl;
		} else if(n == 1) {
			cout << 1 << endl;
		} else {
			LL ans = powmod(2, n) - 2;
			if(ans < 0) ans += p;
			cout << ans << endl;
		}
	}
	return 0;
}