(模板 重要)Tarjan算法解决LCA问题(PAT 1151 LCA in a Binary Tree)_ci

关于最近的公共祖先,如上图所示最近公共祖先是2最近公共祖先最近公共祖先

LCA问题一个好的解决思路是Tarjan算法,关于算法的思想见:javascript:void(0),这篇博客的讲解比较通俗易懂,我根据博主给出的算法思路用代码进行了实现。

int tAncestor = -1;
void tarjan(int root, int LA, int RA, int father) {
	if (root == -1) return;
	tarjan(nmBTree[root].lchild, LA, RA, root);
	tarjan(nmBTree[root].rchild, LA, RA, root);
	if (root == LA || root == RA) {
		if (root == LA) {
			if (visited[RA]) {   //其中一个被访问过,那么那个结点的祖先结点就是公共祖先结点
				tAncestor = nfindAns(RA);
			}
		}
		else {
			if (visited[LA]) {
				tAncestor = nfindAns(LA);
			}
		}
	}
	visited[root] = true;
	nfind[root] = father;
}

下面看例题:

1151 LCA in a Binary Tree (30 point(s))

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y.where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

先建树,然后就可以通过tarjan算法来进行求解,这里A可能是B的祖先结点,B也可能是A的祖先结点,要在最后进行判断

然后结点的数据范围是0-1000,赋值时要稍加注意

#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
const int MAXN = 1001000;
bool visited[MAXN];
int nfind[MAXN];

struct nmNode {
	int lchild, rchild;
	int indexInArray;
}nmBTree[MAXN];
int preOrderArrays[MAXN], inOrderArrays[MAXN];
int N, M;
//建树
int buildBinaryTree(int PreL, int PreR, int inL, int inR) {
	if (PreL > PreR) return -1;
	int curPreRoot = preOrderArrays[PreL];
	int curInroot = -1;
	int k;
	for (k = inL; k <= inR; ++k) {
		if (inOrderArrays[k] == curPreRoot) {
			curInroot = inOrderArrays[k];
			break;
		}
	}
	if (curInroot == -1) return -1;
	int numk = k - inL;  //左边有多少个元素
	nmBTree[curInroot].lchild = buildBinaryTree(PreL + 1, PreL + numk, inL, k - 1);
	nmBTree[curInroot].rchild = buildBinaryTree(PreL + numk + 1, PreR, k + 1, inR);
	return curInroot;
}

int nfindAns(int sroot) {
	if (sroot == nfind[sroot]) return sroot;
	else return nfindAns(nfind[sroot]);
}

int tAncestor = -1;
void tarjan(int root, int LA, int RA, int father) {
	if (root == -1) return;
	tarjan(nmBTree[root].lchild, LA, RA, root);
	tarjan(nmBTree[root].rchild, LA, RA, root);
	if (root == LA || root == RA) {
		if (root == LA) {
			if (visited[RA]) {   //其中一个被访问过,那么那个结点的祖先结点就是公共祖先结点
				tAncestor = nfindAns(RA);
			}
		}
		else {
			if (visited[LA]) {
				tAncestor = nfindAns(LA);
			}
		}
	}
	visited[root] = true;
	nfind[root] = father;
}
bool findnode(int u) { //查找节点 
	for (int i = 0; i < M; i++) {
		if (u == preOrderArrays[i])
			return true;
	}
	return false;
}
int main() {
	cin >> N >> M;
	int nroot;
	for (int i = 0; i < M; ++i) {
		cin >> inOrderArrays[i];
	}
	for (int i = 0; i < M; ++i) {
		cin >> preOrderArrays[i];
		if (i == 0) nroot = preOrderArrays[i];
	}

	int nRoot = buildBinaryTree(0, M - 1, 0, M - 1);  //建树
	for (int i = 0; i < N; ++i) {
		int Pa, Pb;
		cin >> Pa >> Pb;

		if (findnode(Pa) == false && findnode(Pb) == false)
			printf("ERROR: %d and %d are not found.\n", Pa, Pb);
		else if (findnode(Pa) == false || findnode(Pb) == false)
			printf("ERROR: %d is not found.\n", findnode(Pa) == false ? Pa : Pb);
		else {
			//利用tarjan算法求解
			memset(visited, 0, M);
			tAncestor = nroot;
			for (int i = 0; i <= M + 1000; ++i) {  //因为数字从0-1000开始
				nfind[i] = i;
			}
			tarjan(nroot, Pa, Pb, nroot);
			if (Pa == tAncestor) {
				printf("%d is an ancestor of %d.\n", Pa, Pb);
			}
			else if (Pb == tAncestor) {
				printf("%d is an ancestor of %d.\n", Pb, Pa);
			}
			else {
				printf("LCA of %d and %d is %d.\n", Pa, Pb, tAncestor);
			}
		}
	}
	system("PAUSE");
	return 0;
}