C语言实验——打印菱形
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description

从键盘输入一个整数n(1≤n≤9),打印出指定的菱形。
Input

正整数n(1≤n≤9)。
Output

指定的菱形。
第一行前面有n-1个空格,第二行有n-2个空格,依此类推。
Sample Input

5
Sample Output

*







*
import java.util.Scanner;

public class Main 
{
      public static void main (String[] args)
      {
    	  Scanner reader = new Scanner(System.in);
    	  
    	  int N=reader.nextInt();
    	  for(int i=1;i<=N;i++)
    	  {
    		  for(int j=i;j<=N-1;j++)
    		  {
    			  System.out.printf(" ");  
    		  }
    		  for(int j=1;j<=2*i-1;j++)
    		  {
    			  System.out.printf("*");
    		  }
    		  System.out.printf("\n");
    	  }
    	  for(int i=1;i<=N-1;i++)
    	  {
    		  for(int j=1;j<=i;j++)
    		  {
    			  System.out.printf(" ");
    		  }
    		  for(int j=(N-i)*2-1;j>=1;j--)
    		  {
    			  System.out.printf("*");
    		  }
    		  System.out.println();
    	  }
    	
    	  
      }
}

C语言实验——打印数字图形
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description

从键盘输入一个整数n(1≤n≤9),打印出指定的数字图形。
Input

正整数n(1≤n≤9)。
Output

指定数字图形。
Sample Input

5
Sample Output

1

121
12321
1234321
123454321
1234321
12321
121
1

import java.util.Scanner;

public class Main 
{
      public static void main (String[] args)
      {
    	  Scanner reader = new Scanner(System.in);
    	  
    	  int N=reader.nextInt();
    	  for(int i=1;i<=N;i++)
    	  {
    		  for(int j=i;j<=N-1;j++)
    		  {
    			  System.out.printf(" ");  
    		  }
    		  for(int j=1;j<=i;j++)
    		  {
    			  System.out.print(j);
    		  }
    		  for(int j=i-1;j>=1;j--)
    		  {
    			  System.out.print(j);
    		  }
    		  System.out.printf("\n");
    	  }
    	  for(int i=1;i<=N-1;i++)
    	  {
    		  for(int j=1;j<=i;j++)
    		  {
    			  System.out.print(" ");
    		  }
    		  for(int j=1;j<=N-i;j++)
    		  {
    			  System.out.print(j);
    		  }
    		  for(int j=N-i-1;j>=1;j--)
    		  {
    			  System.out.print(j); 
    		  }
    		  System.out.println();
    	  }
    	
    	  
      }
}

统计元音
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description

统计每个元音字母在字符串中出现的次数。
Input

输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串。
Output

对于每个测试实例输出5行,格式如下:

a:num1
e:num2
i:num3
o:num4
u:num5

多个测试实例之间由一个空行隔开。

Sample Input

2
aeiou
my name is ignatius
Sample Output

a:1
e:1
i:1
o:1
u:1

a:2
e:1
i:3
o:0
u:1

import java.util.Scanner;

public class Main
{
	public static void main(String args[])
	{
		Scanner reader=new Scanner(System.in);
		int n=reader.nextInt();
		String S;
		reader.nextLine();		
		for(int i=0;i<n;i++)
		{
			int n1=0,n2=0,n3=0,n4=0,n5=0;
			S=reader.nextLine();
			char[] a=S.toCharArray();
			for(int j=0;j<S.length();j++)
			{
				if(a[j]=='a')
					n1++;				
				else if(a[j]=='e')
					n2++;
				else if(a[j]=='i')
					n3++;
				else if(a[j]=='o')
					n4++;
				else if(a[j]=='u')
					n5++;
			}
			if(i==n-1)
				System.out.println("a:"+n1+"\r\n"+"e:"+n2+"\r\n"+"i:"+n3+"\r\n"+"o:"+n4+"\r\n"+"u:"+n5);
			else
				System.out.println("a:"+n1+"\r\n"+"e:"+n2+"\r\n"+"i:"+n3+"\r\n"+"o:"+n4+"\r\n"+"u:"+n5+"\r\n");
		}
	} 
}

回文串判定
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description

输入一串字符(长度小于100),判断该串字符是否是回文串(正序读与逆序读内容相同)。
Input

输入一串字符(长度小于100)。
Output

若该串字符是回文串输出“yes",否则输出”no“。
Sample Input

asdfgfdsa
Sample Output

yes

import java.util.Scanner;

public class Main
{
	public static void main(String args[])
	{
		Scanner reader=new Scanner(System.in);
		String S;
		S=reader.next();
		char[] A=S.toCharArray();
		int n=S.length();
		int i=0,j=n-1;
		while(i<j)
		{
			if(A[i]!=A[j])
			{
				System.out.println("no");
				break;
			}
			i++;j--;
		}
		if(i>=j)
			System.out.println("yes");
		
	} 
}

字符统计2
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description

输入英文句子,输出该句子中除了空格外出现次数最多的字符及其出现的次数。
Input

输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
Output

逐行输出每个句子中出现次数最多的字符及其出现的次数(如果有多个字符的次数相同,只输出ASCII码最小的字符)。
Sample Input

I am a student
a good programming problem
ABCD abcd ABCD abcd
Sample Output

a 2
o 4
A 2

import java.util.Scanner;
public class Main {
 
	public static void main(String[] args) {
		
		Scanner reader = new Scanner(System.in);
		int[]A =new int[220];
		while(reader.hasNextLine())
		{
			String S;
			S = reader.nextLine();
			int length=S.length();
			for(int i=0;i<220;i++)
			{
				A[i]=0;
			}
			for(int i=0;i<length;i++)
			{
				if(S.charAt(i)!=' ')
				{
					A[S.charAt(i)]++;
				}
				
			}
			int m=0,t=0;
			for(int i=0;i<220;i++)
			{
				if(A[i]>m) 
				{
					m=A[i];
					t=i;
				}
			}
			System.out.printf("%c %d\n",t,m);
		}
		reader.close();
 
	}
 
}