Numbers


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 10    Accepted Submission(s): 9



Problem Description


There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise output "NO".




Input


There are multiple test cases, no more than 1000 cases.
For each case,the line contains a integer N. (0<N<1030)




Output


For each test case,output the answer in a line.




Sample Input


2 3 5 7




Sample Output


YES YES YES NO


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[31];
int main()
{
	int i,sum;
	while(scanf("%s",s)!=EOF)
	{
		sum=0;
		int l=strlen(s);
		for(i=0;i<l;i++)
			sum+=s[i]-'0';
		if(sum%3==0)
			printf("YES\n");
		else if(s[l-1]=='0'||s[l-1]=='2'||s[l-1]=='4'||s[l-1]=='5'||s[l-1]=='6'||s[l-1]=='8')
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}