StrangeStandard
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 284 Accepted Submission(s): 142
Problem Description
Nowadays, WHUACMer use a strange standard to evaluate a natural number.The evaluating value of a natural number is the amount of it’s divisors.If a number m has bigger evaluating value than all the numbers smaller than it, we call it a good number. Now give you a number n, find the maximum good number which is not bigger than n.
Input
The first line contains a single integer T(T<=10), indicating the number of test cases.
For each test case,there is only one line which only contains one number n(1 <= n <= 2 000 000 000)
Output
For each test case,output the case number first,then output the maximum good number which is not bigger than n.
Sample Input
1 1000
Sample Output
Case #1: 840
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef unsigned long long ll;
const ll INF = (ll)1<<63;
ll n;
ll ans;
int m;
int p[16]={2,3,5,7,11,13,17,19,23,29,31,37,41,43,47,53};
void dfs(int gen,ll tmp,int num)
{
if(gen>=16)
return ;
if(num>m)
{
m=num;
ans=tmp;
}
if(num==m&&ans>tmp)
ans=tmp;
for(int i=1;i<=63;i++)
{
if(n/p[gen]<tmp)
break;
dfs(gen+1,tmp*=p[gen],num*(i+1));
}
}
int main()
{
int t,T=1;
scanf("%d",&t);
while(t--)
{
scanf("%lld",&n);
ans=INF;
m=0;
dfs(0,1,1);
printf("Case #%d: %lld\n",T++,ans);
}
return 0;
}