MZL's xor Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 904 Accepted Submission(s): 586


Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all ( Ai + Aj )( 1i,jn )
The xor of an array B is defined as B1 xor B2 ...xor Bn

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers: n , m , z , l
A1=0 , Ai=(Ai1m+z) mod l
1m,z,l5105 , n=5105

Output
For every test.print the answer.

Sample Input
2 3 5 5 7 6 8 8 9

Sample Output
14 16
#include<stdio.h>
#include<string.h>
#define N 500010
int a[5*N];
int main()
{
	int t;
	int n,m,z,l;
	int i,j;
	int sum;
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));
		scanf("%d%d%d%d",&n,&m,&z,&l);
		for(i=2;i<=n;i++)
		{
			a[i]=((long long)a[i-1]*m+z)%l;
		}
		sum=0;
		for(i=1;i<=n;i++)
			sum=sum^(a[i]*2);
		printf("%d\n",sum);
	}
	return 0;
}