|
|
Max SumTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Problem Description
Input
Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input 2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output Case 1: 14 1 4 Case 2: 7 1 6
Author Ignatius.L |
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
int t, i;
Scanner in = new Scanner(System.in);
t = in.nextInt();
for (i = 0; i < t; i++) {
anster(in, i + 1);
if (i != t - 1)
System.out.println();
}
}
private static void anster(Scanner in, int k) {
int l = 0;
int r = 0;
int sum = 0;
int count = in.nextInt();
int num;
int max = -1001;
int tempStep = 1;
for (int i = 0; i < count; i++) {
num = in.nextInt();
sum = sum + num;
if (sum > max) {
l = tempStep;
r = i + 1;
max = sum;
}
if (sum < 0) {
sum = 0;
tempStep = i + 2;
}
}
System.out.println("Case " + k + ":");
System.out.println(max + " " + l + " " + r);
}
}