GCD


Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11002    Accepted Submission(s): 4161


Problem Description


Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.


 



Input


The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.


 



Output


For each test case, print the number of choices. Use the format in the example.


 



Sample Input


2 1 3 1 5 1 1 11014 1 14409 9


 



Sample Output


Hint

For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).



 



Source


​2008 “Sunline Cup” National Invitational Contest ​


 



Recommend


wangye   |   We have carefully selected several similar problems for you:   ​​1689​​​  ​​​1690​​​  ​​​1693​​​  ​​​1691​​​  ​​​1692​​ 






【分析】


莫比乌斯反演,注意gcd(a,b)和gcd(b,a)算作相同,注意k==0的情况






【代码】


//hdu 1695 GCD
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 100000
#define ll long long
#define M(a) memset(a,0,sizeof a)
#define fo(i,j,k) for(int i=j;i<=k;i++)
using namespace std;
const int mxn=100005;
bool vis[mxn];
int a,b,c,d,k,T;
int pri[mxn],miu[mxn];
inline void shai()
{
miu[1]=1;
fo(i,2,N)
{
if(!vis[i]) pri[++pri[0]]=i,miu[i]=-1;
for(int j=1;j<=pri[0] && i*pri[j]<=N;j++)
{
vis[i*pri[j]]=1;
if(i%pri[j]==0) break;
miu[i*pri[j]]=-miu[i];
}
}
fo(i,1,N) miu[i]+=miu[i-1];
}
inline ll solve(int n,int m)
{
ll ans1=0,ans2=0;
if(n>m) swap(n,m);
for(int i=1,last=0;i<=n;i=last+1)
{
last=min(n/(n/i),m/(m/i));
ans1+=(ll)(miu[last]-miu[i-1])*(n/i)*(m/i);
ans2+=(ll)(miu[last]-miu[i-1])*(n/i)*(n/i);
}
return ans1-ans2/2;
}
int main()
{
shai();
scanf("%d",&T);
fo(i,1,T)
{
scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
if(!k) printf("Case %d: 0\n",i);
else printf("Case %d: %lld\n",i,solve(b/k,d/k));
}
return 0;
}