A Simple Task

Problem Description
Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

Example

For n = 24, o = 3 and p = 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the odd integer o and the nonnegative integer p such that n = o2^p,

writes the result.

Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

Sample Input
1
24

Sample Output
3 3

题意:n = o*2^p;成立的o,p奇数

# include <iostream>
# include <cstdio>

int main(){

int n,m;

while(scanf("%d",&n)!=EOF){

while(n--){
scanf("%d",&m);
int cnt = 0;
while(m%2==0){
cnt++;
m = m/2;
}

printf("%d %d\n",m,cnt);
}

}



return 0;
}