Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd aaaa ababab .

Sample Output

1 4 3

 找一个串的最小循环节的个数.。

先求出next数组,然后使用长度-next【len】就是最小循环节的长度。然后特判就行。

AC代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stdlib.h>
#include<queue>
#include<map>
#include<set>
#include<iomanip>
#include<math.h>
using namespace std;
typedef long long ll;
typedef double ld;
char p[1000010 ];
int m,nxt[1000010 ];

void GetNext(char* p, int nxt[])
{
int pLen=strlen(p);
nxt[0]=-1;
int k=-1;
int j=0;
while(j<pLen)
{
//p[k]表示前缀,p[j]表示后缀
if(k==-1||p[j]==p[k])
{
++j;
++k;
//较之前next数组求法,改动在下面4行
if(p[j]!=p[k])
nxt[j]=k; //之前只有这一行
else
//因为不能出现p[j] = p[ next[j ]],所以当出现时需要继续递归,k = next[k] = next[next[k]]
nxt[j]=nxt[k];
}
else
{
k=nxt[k];
}
}
}

int main()
{
while(scanf("%s",p)!=EOF)
{
if(p[0]=='.')
break;
int len=strlen(p);
GetNext(p,nxt);
int ans=1;
if(!(len%(len-nxt[len])))
ans=len/(len-nxt[len]);
printf("%d\n",ans);
}
return 0;
}