用并查集来判断是否存在回路,详见算法导论


​http://acm.hdu.edu.cn/showproblem.php?pid=1863​



Problem Description


省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。


 



Input


测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。


 



Output


对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。


 



Sample Input


3 3 1 2 1 1 3 2 2 3 4 1 3 2 3 2 0 100


 



Sample Output


3 ?




#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

struct edge{
int a;
int b;
int w;
}e[110];

struct cmp{
bool operator() (const edge& a, const edge& b){
return a.w < b.w;
}
};

int set[110];

int find(int x){
int r = x;
while (r != set[r]){
r = set[r];
}

int i = x;
while (set[i] != r){
int j = set[i];
set[i] = r;
i = j;
}

return r;
}


int main(){

int N, M;

//freopen("test.txt", "r", stdin);

while (scanf("%d%d", &N, &M)!=EOF){
if (N == 0) break;
for (int i = 0; i < N; i++){
cin >> e[i].a >> e[i].b >> e[i].w;
}

for (int i = 1; i <= M; i++){
set[i] = i;
}

sort(e, e + N, cmp());

int cntw = 0, cntn = 0;

for (int i = 0; i < N; i++){
int a = e[i].a;
int b = e[i].b;

int ra = find(a);
int rb = find(b);

if (ra != rb){
set[rb] = ra;

cntw += e[i].w;
//cntn++;
}

}

for (int i = 1; i <= M; i++){
if (set[i] == i)
cntn++;
}

if (cntn == 1){
cout << cntw << endl;
}
else{
cout << "?" << endl;
}

}

return 0;
}


统计跟为1AC,但是统计MST边个数为N-1出错,不知道为什么