Flip Game


Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 41388

 

Accepted: 17971


Description


Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


POJ 1753Flip Game(暴力+Dfs)_i++

Consider the following position as an example: 



bwbw 


wwww 


bbwb 


bwwb 


Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 



bwbw 


bwww 


wwwb 


wwwb 


The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 



Input


The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.


Output


Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).


Sample Input


bwwb bbwb bwwb bwww


Sample Output


4


题意:棋盘上共有16颗棋子,每个棋子只有黑白两种状态,故我可以将其看成一个16为的二进制数,黑为1白为0,每次翻棋子生成的棋盘相当于跟对应的数做一次异或运算,最后用一个广深搜将搞定。



#include <iostream>
#include <string.h>

using namespace std;
bool map[5][5];
int step;
int flag;

bool all_color()//判断是否都是一个颜色;
{
int i, j;
for(i = 0; i < 4; i++)
for(j = 0; j < 4; j++)
if(map[0][0] != map[i][j])
return false;
return true;
}

void cheng_color(int i, int j)//改变上下左右中的颜色;
{
map[i][j] = !map[i][j];
if(i > 0)
map[i - 1][j] = !map[i - 1][j];//bool类型中a = !a的意思是a等于a的反面。
if(i < 3)
map[i + 1][j] = !map[i + 1][j];
if(j > 0)
map[i][j - 1] = !map[i][j - 1];
if(j < 3)
map[i][j + 1] = !map[i][j + 1];
return ;
}

void DFS(int r, int c, int deep)
{
if(deep == step)
{
flag = all_color();//记录当前的状态,判断是否满足条件
return ;
}
if(flag || r == 4)//flag = 1说明清一色,r = 4 说明全部走完了一遍。
return ;
cheng_color(r, c);
if(c < 3)
DFS(r, c + 1, deep + 1);
else
DFS(r + 1, 0, deep + 1);
cheng_color(r, c);
if(c < 3)
DFS(r, c + 1, deep);
else
DFS(r + 1, 0, deep);
return ;
}

int main()
{
int i, j;
char e;
memset(map, false, sizeof(map));
for(i = 0; i < 4; i++)
{
for(j = 0; j < 4; j++)
{
cin>>e;
if(e == 'b')
map[i][j] = true;
}
}
for(step = 0; step <= 16; step++)
{
DFS(0, 0, 0);
if(flag)
break;
}
if(flag)
cout<<step<<endl;
else
cout<<"Impossible"<<endl;
return 0;
}