Sudoku


Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 18995

 

Accepted: 9143

 

Special Judge


Description


Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

POJ 2676Sudoku(Dfs+搜索剪枝)_git


Input


The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.


Output


For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.


Sample Input


1103000509 002109400 000704000 300502006 060000050 700803004 000401000 009205800 804000107


Sample Output


143628579572139468 986754231 391542786 468917352 725863914 237481695 619275843 854396127


Source


#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

int Map[10][10], flag;

bool juedg(int num, int r, int c)
{
int i, j;
int ri, ci;

for(i = 0; i < 9; i++)
{
if(Map[r][i] == num)
return false;
}
for(i = 0; i < 9; i++)
{
if(Map[i][c] == num)
return false;
}
ri = r / 3 * 3;
ci = c / 3 * 3;
int rj = ri + 3, cj = ci + 3;
for(i = ri; i < rj; i++)
{
for(j = ci; j < cj; j++)
{
if(Map[i][j] == num)
return false;
}
}
return true;
}

void Dfs(int n)
{
int ri, ci, i;
ri = n / 9;
ci = n % 9;
if(n > 80 || flag)
{
flag = 1;
return ;
}
if(Map[ri][ci] != 0)
{
Dfs(n + 1);
if(flag)
return ;
}
else
{
for(i = 1; i <= 9; i++)
{
if(juedg(i, ri, ci))
{
Map[ri][ci] = i;
Dfs(n + 1);
if(flag)
return ;
Map[ri][ci] = 0;
}
}
}
}

int main()
{
int K;
scanf("%d", &K);
while(K--)
{
int i, j;
char str[10];
memset(Map, 0, sizeof(Map));
for(i = 0; i < 9; i++)
{
scanf("%s", str);
for(j = 0; j < 9; j++)
Map[i][j] = str[j] - '0';
}
flag = 0;
Dfs(0);
for(i = 0; i < 9; i++)
{
for(j = 0; j < 9; j++)
printf("%d", Map[i][j]);
printf("\n");
}
}
return 0;
}