Problem Description


As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”. 
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.


 



Input


The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|


 



Output


For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.


 



Sample Input


4 hehehe hehe woquxizaolehehe woquxizaole hehehehe hehe owoadiuhzgneninougur iehiehieh


 



Sample Output


Hint

In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”.

In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.





用kmp确定每个匹配的位置,用dp统计答案。


#include<set>
#include<map>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int mod = 1e9 + 7;
const int N = 1e5 + 10;
const int INF = 0x7FFFFFFF;
int T, n, f[N], nt[N], cas = 0;
char S[N], s[N];

int main()
{
scanf("%d", &T);
while (T--)
{
scanf("%s%s", S, s);
nt[0] = -1; n = strlen(S);
for (int i = 0; s[i]; i++)
{
int k = nt[i];
while (k >= 0 && s[i] != s[k]) k = nt[k];
nt[i + 1] = k + 1;
}
f[0] = 1;
for (int i = 0, j = nt[1]; S[i];)
{
if (j < 0 || S[i] == s[j])
{
f[i + 1] = f[i];
i++, j++;
if (!s[j]) f[i] = (f[i] + f[i - j]) % mod;
}
else j = nt[j];
}
printf("Case #%d: %d\n", ++cas, f[n]);
}
return 0;
}