Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 40299    Accepted Submission(s): 16619


Problem Description


Given two sequences of numbers : a[1], a[2], …… , a[N], and b[1], b[2], …… , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], …… , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 


Input


The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], …… , a[N]. The third line contains M integers which indicate b[1], b[2], …… , b[M]. All integers are in the range of [-1000000, 1000000].

 


Output


For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 


Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 


Sample Output

6
-1

 



KMP算法,裸题

找母串中与子串匹配的最小下标


#include<bits/stdc++.h>
using namespace std;
const int MAXN=1e6+7;
int s[MAXN],p[MAXN];
int slen,plen;
int nex[MAXN];

void GetNext()
{
int i,j;
i=0;
j=nex[0]=-1;
while(i<plen)
{
while(-1!=j&&p[i]!=p[j]) j=nex[j];
if(p[++i]==p[++j]) nex[i]=nex[j];
else nex[i]=j;
}
}

int KMP()
{
GetNext();
int i,j;
i=j=0;
while(i<slen&&j<plen)
{
while(-1!=j && s[i]!=p[j]) j=nex[j];
i++;j++;
}
if(j==plen)
return i-j+1;
else
return -1;
}


int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&slen,&plen);
for(int i=0;i<slen;i++) scanf("%d",&s[i]);
for(int i=0;i<plen;i++) scanf("%d",&p[i]);
printf("%d\n",KMP());
}
return 0;
}