问题 A: Least Common Multiple

时间限制: 1 Sec  内存限制: 32 MB
 

题目描述

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

输入

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

输出

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

样例输入


2 2 3 5 3 4 6 12


样例输出


15 12


经验总结

题目其实就是求最小公倍数,原理就是利用最大公约数,A*B/(gcd(A,B) ),多个数原理相同~~

AC代码

#include <cstdio>
int gcd(int a,int b)
{
return !b?a:gcd(b,a%b);
}
int main()
{
int n,m;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
{
scanf("%d",&m);
int first,d;
scanf("%d",&first);
for(int j=0;j<m-1;j++)
{
int temp;
scanf("%d",&temp);
d=gcd(first,temp);
if(d==0)
{
first=0;
break;
}
first=first/d*temp;
}
printf("%d\n",first);
}
}
return 0;
}