Smith Numbers


Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 13142

 

Accepted: 4484


Description


While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way: 
4937775= 3*5*5*65837
The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers. 
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition. 
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!


Input


The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.


Output


For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.


Sample Input


4937774 0


Sample Output


4937775




题意:对于一个数n,如果它的各个位的和等于它质因数的和,并且这个数不是素数,满足以上情况就是smith数。英语是硬伤,由于没有看到smith数不能是素数,WA了好几次。 求:大于n的最小的smith数(一定存在)



代码:

#include<stdio.h>
int a[1000010];
int isprime(int n)//判断是否为素数
{
for(int i=2;i*i<=n+1;i++)
{
if(n%i==0)
{
return 1;
}
}
return 0;
}
int tmp(int n)//求一个数每位的和
{
int k=0;
while(n)
{
k+=(n%10);
n/=10;
}
return k;
}
int ans(int n) //将求一个数的所有质因数,并将它们存入数组a
{
int len=0;
for(int i=2;i*i<=n;i++)
{
while(n%i==0)
{
a[len++]=i;
n/=i;
}
}
if(n>1)
a[len++]=n;
return len;
}
int main()
{
int i,j,n,sum,len;
while(scanf("%d",&n),n)
{
for(i=n+1;;i++)
{
len=ans(i);
for(j=0,sum=0;j<len;j++)
{
sum+=tmp(a[j]);
}
if(isprime(i)&&tmp(i)==sum)
{
printf("%d\n",i);
break;
}
}
}
}