Rightmost Digit


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33558    Accepted Submission(s): 12831


Problem Description


Given a positive integer N, you should output the most right digit of N^N.


 



Input


The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).


 



Output


For each test case, you should output the rightmost digit of N^N.


 



Sample Input


2 3 4


 



Sample Output


Hint


 



Author


Ignatius.L


/*求N^N的最低位。只能观察尾数的规律。 
很容易发现0,1,5,6的任何次幂都为本身。
2,3,7,8是每四次幂循环一次。4,9均是每两次幂一循环
*/
#include<stdio.h>
int a[10][4]={{0},{1},{6,2,4,8},{1,3,9,7},{6,4},{5},{6},{1,7,9,3},{6,8,4,2},{1,9}};
int main()
{
int test,n;
scanf("%d",&test);
while(test--)
{
scanf("%d",&n);
if(n%10==0||n%10==1||n%10==5||n%10==6)
printf("%d\n",a[n%10][0]);
if(n%10==4||n%10==9)
printf("%d\n",a[n%10][n%2]);
if(n%10==2||n%10==3||n%10==7||n%10==8)
printf("%d\n",a[n%10][n%4]);
}
return 0;
}