Eddy's research II

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4366    Accepted Submission(s): 1607

Problem Description

As is known, Ackermann function plays an important role in the sphere of theoretical computer science. However, in the other hand, the dramatic fast increasing pace of the function caused the value of Ackermann function hard to calcuate.


Ackermann function can be defined recursively as follows:



Now Eddy Gives you two numbers: m and n, your task is to compute the value of A(m,n) .This is so easy problem,If you slove this problem,you will receive a prize(Eddy will invite you to hdu restaurant to have supper).

Input

Each line of the input will have two integers, namely m, n, where 0 < m < =3.
Note that when m<3, n can be any integer less than 1000000, while m=3, the value of n is restricted within 24.
Input is terminated by end of file.


Output

For each value of m,n, print out the value of A(m,n).

Sample Input

1 3
2 4


Sample Output


5
11


Author


eddy


Recommend


JGShining   |   We have carefully selected several similar problems for you:  ​​1158​​​ ​​1159​​​ ​​1203​​​ ​​1114​​​ ​​1074​​ 


题解:


数学推导:


m=0时 A(m,n)=n+1。
m=1时 A(m,n)=A(0,A(1,n-1))=A(1,n-1)+1=A(1,n-2)+1+1=……=n+2。
m=2时 A(m,n)=A(m,n-1)+2=2*n+3。
m=3时 A(m,n)=A(2,A(m,n-1))=A(m,n-1)*2+3。


AC代码:


#include<bits/stdc++.h>
using namespace std;
long long A(long long m,long long n)
{
if(n==0) return A(m-1,1);
else if(m==0)return n+1;
else if(m==1) return n+2;
else if(m==2) return A(m,n-1)+2;
else if(m==3)return A(m,n-1)*2+3;
}
int main()
{
long long n,m;
while(~scanf("%lld%lld",&m,&n))
printf("%lld\n",A(m,n));
return 0;
}