A Simple Task

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4640    Accepted Submission(s): 2554

Problem Description

Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.

Example

For n = 24, o = 3 and p = 3.

Task
Write a program which for each data set:
reads a positive integer n,
computes the odd integer o and the nonnegative integer p such that n = o2^p,
writes the result.

Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.

 

Sample Input

1
24

Sample Output

3 3

 

Source

​Central Europe 2001, Practice ​

题解:暴力枚举.....

AC代码:


#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
int main()
{
int n,m,T,i,o;
cin>>T;
while(T--)
{
cin>>n;
for( i=0;i<=20;i++)
{
m=(int)pow(2.0,(double)i); //o*m
o=n/m;
if(n%m==0&&o%2==1) break;
}
printf("%d %d\n",o,i);

}
return 0;
}