Big Number


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34415    Accepted Submission(s): 16289


Problem Description


In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.



Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.




Output

The output contains the number of digits in the factorial of the integers appearing in the input.



Sample Input

2
10
20


Sample Output


7
19



Source

​Asia 2002, Dhaka (Bengal) ​



Recommend

JGShining   |   We have carefully selected several similar problems for you:  ​​1071​​​ ​​1020​​​ ​​1009​​​ ​​1065​​​ ​​1042​​ 




题意:求一个数的阶乘的长度。


题解:任意一个正整数a的位数
等于(int)log10(a) + 1;推导一下:
  对于任意一个给定的正整数a,
  假设10^(x-1)<=a<10^x,那么显然a的位数为x位,
  又因为
  log10(10^(x-1))<=log10(a)<(log10(10^x))
  即x-1<=log10(a)<x
  则(int)log10(a)=x-1,
  即(int)log10(a)+1=x
  即a的位数是(int)log10(a)+1

我们知道了一个正整数a的位数等于(int)log10(a) + 1,
现在来求n的阶乘的位数:
假设A=n!=1*2*3*......*n,那么我们要求的就是
(int)log10(A)+1,而:
log10(A)
        =log10(1*2*3*......n)  (根据log10(a*b) = log10(a) + log10(b)有)
        =log10(1)+log10(2)+log10(3)+......+log10(n)
也就是将求n的阶乘的位数分解成了求n个数对10取对数的和,并且对于其中任意一个数,都在正常的数字范围之类。

总结一下:n的阶乘的位数等于


AC代码:


#include<iostream>
#include<cmath>
using namespace std;
int main()
{
int n,i,T;
double sum;
cin>>T;
while(T--){
cin>>n;
sum=0.0;
for(i=2;i<=n;i++){
sum+=log10(i);
}
cout<<(int)sum+1<<endl;
}
return 0;
}