In mathematics, and more specifically in graph theory, a tree is an undirected graph in which any two
nodes are connected by exactly one path. In other words, any connected graph without simple cycles
is a tree.
You find a partial tree on the way home. This tree has n nodes but lacks of n − 1 edges. You
want to complete this tree by adding n − 1 edges. There must be exactly one path between any two
nodes after adding. As you know, there are n
n−2 ways to complete this tree, and you want to make
the completed tree as cool as possible. The coolness of a tree is the sum of coolness of its nodes. The
coolness of a node is f(d), where f is a predefined function and d is the degree of this node. What’s
the maximum coolness of the completed tree?
Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with
an integer n in one line, then one line with n − 1 integers f(1), f(2), . . . , f(n − 1).
• 1 ≤ T ≤ 2015
• 2 ≤ n ≤ 2015
• 0 ≤ f(i) ≤ 10000
• There are at most 10 test cases with n > 100.
Output
For each test case, please output the maximum coolness of the completed tree in one line.
Sample Input
2
3
2 1
4
5 1 4
Sample Output
5
19

题目大概:

给你一个树的结点数量n,让你构造一棵树,使得这棵树的价值最大,每个结点都有一个价值,度数d,每个结点的价值为f(d)。这棵树的价值为所有结点的价值之和。f(1),f(2)....f(n-2),f(n-1)这些价值都会给出。

思路:

首先感觉这很像是一个背包问题,有一个固定的总度数2*n-2,每个度数都有一个价值,求最大价值max是多少。

但是每个结点有个限制,就是最少度数为1。那么我们可以预先为每个结点分1度,那么这时候树的价值为sum=n*f(1)。

这时候还有n-2度,然后需要计算出n-2度的背包的最大值。

这时候不能忘记我们已经给每个结点分配了1度的价值了,所以在背包中,每次添加一个物品的时候,需要把度为1的物品的价值给减去,防止多计算。

理清楚了所有内容,直接写背包就行了。

代码:

#include <bits/stdc++.h>

using namespace std;
const int INF=0x3f3f3f3f;
#define ll long long
const int maxn=2e4+10;
int dp[maxn];
int w[maxn];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
for(int i=1;i<n;i++)
{
scanf("%d",&w[i]);
}
for(int i=0;i<=n;i++)dp[i]=-INF;
int sum=w[1]*n;
int m=n-2;
dp[0]=0;//初始化
for(int i=1;i<n-1;i++)
{
for(int j=i;j<=m;j++)
{
if(dp[j]<dp[j-i]+w[i+1]-w[1])
{
dp[j]=dp[j-i]+w[i+1]-w[1];
}
}
}
printf("%d\n",dp[m]+sum);
}
return 0;
}