描述

The circus clown Sunny has a magic box. When the circus is performing, Sunny puts some balls into the box one by one. The balls are in three colors: red(R), yellow(Y) and blue(B). Let Cr, Cy, Cb denote the numbers of red, yellow, blue balls in the box. Whenever the differences among Cr, Cy, Cb happen to be x, y, z, all balls in the box vanish. Given x, y, z and the sequence in which Sunny put the balls, you are to find what is the maximum number of balls in the box ever.

For example, let's assume x=1, y=2, z=3 and the sequence is RRYBRBRYBRY. After Sunny puts the first 7 balls, RRYBRBR, into the box, Cr, Cy, Cb are 4, 1, 2 respectively. The differences are exactly 1, 2, 3. (|Cr-Cy|=3, |Cy-Cb|=1, |Cb-Cr|=2) Then all the 7 balls vanish. Finally there are 4 balls in the box, after Sunny puts the remaining balls. So the box contains 7 balls at most, after Sunny puts the first 7 balls and before they vanish.

输入

Line 1: x y z

Line 2: the sequence consisting of only three characters 'R', 'Y' and 'B'.

For 30% data, the length of the sequence is no more than 200.

For 100% data, the length of the sequence is no more than 20,000, 0 <= x, y, z <= 20.

输出

The maximum number of balls in the box ever.

提示

Another Sample

Sample Input

Sample Output

0 0 0

RBYRRBY            

4



样例输入

1 2 3
RRYBRBRYBRY

样例输出

7


这种类型的题应该遇到比较多了,应该是做法很类似的题,比赛也遇到很多,都是利用几个变量,在遍历数据的时候进行加减等操作,模拟某些过程,发个模板类题,留个印记。

代码:


#include <bits/stdc++.h>

using namespace std;
const int N = 1111111;
int a[N];
int b[3];
int c[3];
int pan(int q[],int w[])
{
int a[3];
for(int i=0;i<3;i++)
{
a[i]=abs(w[i]);
}
sort(a,a+3);
for(int i=0;i<3;i++)
{
if(q[i]!=a[i])return 0;
}
return 1;
}
int main(){

while(~scanf("%d%d%d",&c[0],&c[1],&c[2]))
{
memset(b,0,sizeof(b));
sort(c,c+3);
string s;
cin>>s;
int l=s.length();
int ans=0;
int sum=0;
for(int i=0;i<l;i++)
{

if(s[i]=='R')
{
b[2]++;
b[1]--;
}
else if(s[i]=='Y')
{
b[2]--;
b[0]++;
}else if(s[i]=='B')
{
b[1]++;
b[0]--;
}
ans++;
if(pan(c,b))
{
if(sum<ans)sum=ans;
ans=0;
memset(b,0,sizeof(b));
}
}
if(sum<ans)sum=ans;
printf("%d\n",sum);
}

return 0;
}