​http://www.elijahqi.win/archives/528​​​
Mr. White, a fat man, now is crazy about a game named “Dance, Dance, Revolution”. But his dance skill is so poor that he could not dance a dance, even if he dances arduously every time. Does “DDR” just mean him a perfect method to squander his pounds? No way. He still expects that he will be regarded as “Terpsichorean White” one day. So he is considering writing a program to plan the movement sequence of his feet, so that he may save his strength on dancing. Now he looks forward to dancing easily instead of sweatily. “DDR” is a dancing game that requires the dancer to use his feet to tread on the points according to the direction sequenceinthegame. Thereareonecentralpointandfourside points in the game. Those side points are classified as top, left, bottom and right. For the sake of explanation, we mark them integers. That is, the central point is 0, the top is 1, the left is 2, the bottom is 3, and the right is 4, as the figure on the right shows. At the beginning the dancer’s two feet stay on the central point. According to the direction sequence, the dancer has to move one of his feet to the special points. For example, if the sequence requires him to move to the top point at first, he may move either of his feet from point 0 to point 1 (Note: Not both of his feet). Also, if the sequence then requires him to move to the bottom point, he may move either of his feet to point 3, regardless whether to use the foot that stays on point 0 or the one that stays on point 1. There is a strange rule in the game: moving both of his feet to the same point is not allowed. For instance, if the sequence requires the dancer to the bottom point and one of his feet already sta ys on point 3, he should stay the very foot on the same point and tread again, instead of moving the other one to point 3. After dancing for a long time, Mr. White can calculate how much strength will be consumed when he moves from one point to another. Moving one of his feet from the central point to any side points will consume 2 units of his strength. Moving from one side point to another adjacent side point will consume 3 units, such as from the top point to the left point. Moving from one side point to the opposite side point will consume 4 units, such as from the top point to the bottom point. Yet, if he stays on the same point and tread again, he will use 1 unit. Assume that the sequence requires Mr. White to move to point 1 → 2 → 2 → 4. His feet may stays on (point 0, point 0) → (0,1) → (2,1) → (2,1) → (2,4). In this couple of integers, the former number represents the point of his left foot, and the latter represents the point of his right foot. In this way, he has to consume 8 units of his strength. If he tries another pas, he will have to consume much more strength. The 8 units of strength is the least cost. Input Theinputfilewillconsistofaseriesofdirectionsequences. Eachdirectionsequencecontainsasequence of numbers. Each number should either be ‘1’, ‘2’, ‘3’, or ‘4’, and each represents one of the four directions. A value of ‘0’ in the direction sequence indicates the end of direction sequence. And this value should be excluded from the direction sequence. The input file ends if the sequence contains a single ‘0’. Output For each direction sequence, print the least units of strength will be consumed. The result should be a single integer on a line by itself. Any more white spaces or blank lines are not allowable. Sample Input 1 2 2 4 0 1 2 3 4 1 2 3 3 4 2 0 0 Sample Output 8 22

我 ii写在了freopen的后面,结果 每次都//了 就一直一直wa 我 很冷漠

f[i][x][y] 表示跳完第i个舞步,左脚在x,右脚在y所需花费的最小体力。状态转移方程:

f[i][x][a[i]]=min(f[i][x][a[i]],f[i−1][x][y]+move(y,a[i]))

#include<cstdio>
#include<cmath>
#include<cstring>
#define inf 0x3f3f3f3f
#define N 11000
int n;
inline int min(int x,int y){
return x<y?x:y;
}
inline int move(int x,int y){
if (x==y) return 1;if (x==0||y==0) return 2;
int tmp=std::abs(x-y);if (tmp==1||tmp==3) return 3; if (tmp==2) return 4;
}
int f[N][5][5],ans,a[N],ii;
int main(){
freopen("uva1291.in","r",stdin);
ii=1;
while (~scanf("%d",&a[ii])&&a[ii]){
memset(f,0x3f,sizeof(f));f[0][0][0]=0;
while (~scanf("%d",&a[++ii])&&a[ii]);
n=ii-1;
for (int i=1;i<=n;++i)
for (int x=0;x<=4;++x)
for (int y=0;y<=4;++y){
f[i][x][a[i]]=min(f[i][x][a[i]],f[i-1][x][y]+move(y,a[i]));
f[i][a[i]][y]=min(f[i][a[i]][y],f[i-1][x][y]+move(x,a[i]));
}
ans=inf;
for (int i=0;i<=4;++i) ans=min(ans,min(f[n][i][a[n]],f[n][a[n]][i]));
printf("%d\n",ans);
ii=1;
}
return 0;
}