这个题目就有意思了,要求输入一个数n,然后有一行数,都是0,我们可以设定为n个,然后是经过n次 的转换,转换有n次,假设当前使i,如果n%i==0的话,就变换一次(0变成1,1变成0)


Problem Description


There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).


 


Input


Each test case contains only a number n ( 0< n<= 10^5) in a line.



Output


Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).


 


Sample Input


1 5


 


Sample Output


Hint

hint


Consider the second test case: The initial condition : 0 0 0 0 0 … After the first operation : 1 1 1 1 1 … After the second operation : 1 0 1 0 1 … After the third operation : 1 0 0 0 1 … After the fourth operation : 1 0 0 1 1 … After the fifth operation : 1 0 0 1 0 … The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.



import java.util.Scanner;

public class P2053 {
private static Scanner scanner;
public static void main(String[] args) {
scanner = new Scanner(System.in);
while(scanner.hasNext()){
int n = scanner.nextInt();
int k = 0;
for (int i = 1; i <= n; i++) {
if(n%i == 0){//如果是倍数就改变
if(k==0){
k = 1;
}else {
k = 0;
}
}
}
System.out.println(k);
}
}
}