Eddy's research I


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10709    Accepted Submission(s): 6619


Problem Description


Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .


 



Input


The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.


 



Output


You have to print a line in the output for each entry with the answer to the previous question.


 



Sample Input


11 9412


 



Sample Output


11 2*2*13*181


先将1 < x<= 65535内的素数存起来,然后从第一个开始判断能否整除,要是能整除,


输出该数,在从该素数开始判断是否能整除,,,如此类推


import java.util.Scanner;

public class Main {
private static Scanner scanner;
private static int arr[];
private static boolean isPrime[];
public static void main(String[] args) {
scanner = new Scanner(System.in);
dabiao();
while(scanner.hasNext()){
int n = scanner.nextInt();
boolean isFirst = true;
int t = 0;
while(n!=1){
for (int i = t; i < arr.length; i++) {
if(n%arr[i] == 0){
t = i;
if(isFirst){
System.out.print(arr[i]);
isFirst = false;
}else {
System.out.print("*"+arr[i]);
}
n /= arr[i];
break;
}
}
}
System.out.println();
}
}
private static void dabiao() {
isPrime = new boolean[65536];
arr = new int[6542];
for (int i = 0; i < isPrime.length; i++) {
isPrime[i] = true;
}
for (int i = 2; i < isPrime.length; i++) {
if(isPrime[i]){
for (int j = i+i; j < isPrime.length; j+=i) {
isPrime[j] = false;
}
}
}
int t = 0;
for (int i = 2; i < isPrime.length; i++) {
if(isPrime[i]){
arr[t] = i;
t++;
}
}
}
}