As Easy As A+B


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 66393    Accepted Submission(s): 28436


Problem Description


These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!


 



Input


Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line.
It is guarantied that all integers are in the range of 32-int.


 



Output


For each case, print the sorting result, and one line one case.


 



Sample Input


2 3 2 1 3 9 1 4 7 2 5 8 3 6 9


 



Sample Output


1 2 3 1 2 3 4 5 6 7 8 9


 


排序题,数据量有限,并不需要使用java不常用的快速输入输出的方式,因为就快不了多少。




import java.util.Arrays;
import java.util.Scanner;

public class Main{
private static Scanner scanner;

public static void main(String[] args) {
scanner = new Scanner(System.in);
int cases = scanner.nextInt();
while (cases-- > 0) {
int n = scanner.nextInt();
int arr[] = new int[n];
for (int i = 0; i < n; i++) {
arr[i] = scanner.nextInt();
}
Arrays.sort(arr);

System.out.print(arr[0]);
for (int i = 1; i < n; i++) {
System.out.print(" " + arr[i]);
System.out.flush();
}
System.out.println();
}
}
}


//只是快了一点
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.OutputStreamWriter;
import java.io.PrintWriter;
import java.io.StreamTokenizer;
import java.util.Arrays;
public class Main{
public static void main(String[] args) throws IOException {
StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
PrintWriter out = new PrintWriter(new OutputStreamWriter(System.out));

in.nextToken();// 指向下一个数据
int cases = (int) in.nval;
while (cases-- > 0) {
in.nextToken();
int n = (int) in.nval;// 指向下一个数据
int arr[] = new int[n];
for (int i = 0; i < n; i++) {
in.nextToken();
arr[i] = (int) in.nval;
}
Arrays.sort(arr);
// 刷新,不然会留在缓冲区
out.print(arr[0]);
out.flush();
for (int i = 1; i < n; i++) {
out.print(" " + arr[i]);
out.flush();
}
System.out.println();
}
}
}

Run ID

Submit Time

Judge Status

Pro.ID

Exe.Time

Exe.Memory

Code Len.

Language

Author

23047772

2017-11-28 15:42:32

Accepted

​1040​

218MS

7652K

​968 B​

Java

​逸川同学​

23047581

2017-11-28 15:31:55

Accepted

​1040​

343MS

10556K

​607 B​

Java

​逸川同学​