题目描述
小
QQ
Q是一个非常聪明的孩子,除了国际象棋,他还很喜欢玩一个电脑益智游戏――矩阵游戏。矩阵游戏在一个
N×NN \times N
N×N黑白方阵进行(如同国际象棋一般,只是颜色是随意的)。每次可以对该矩阵进行两种操作:
行交换操作:选择矩阵的任意两行,交换这两行(即交换对应格子的颜色)
列交换操作:选择矩阵的任意两列,交换这两列(即交换对应格子的颜色)
游戏的目标,即通过若干次操作,使得方阵的主对角线(左上角到右下角的连线)上的格子均为黑色。
对于某些关卡,小
QQ
Q百思不得其解,以致他开始怀疑这些关卡是不是根本就是无解的!于是小
QQ
Q决定写一个程序来判断这些关卡是否有解。
输入输出格式
输入格式:
第一行包含一个整数
TT
T,表示数据的组数。
接下来包含
TT
T组数据,每组数据第一行为一个整数
NN
N,表示方阵的大小;接下来
NN
N行为一个
N×NN \times N
N×N的
0101
01矩阵(
00
0表示白色,
11
1表示黑色)。
输出格式:
包含
TT
T行。对于每一组数据,如果该关卡有解,输出一行
YesYes
Yes;否则输出一行
NoNo
No。
输入输出样例
输入样例#1: 复制
2
2
0 0
0 1
3
0 0 1
0 1 0
1 0 0
输出样例#1: 复制
No
Yes
思路:
最终状态是 (1,1)(2,2)…(n,n)都有黑点,
即n行和n列都有匹配;
所以由s向每列连边,t与每列连边;那么1即为列与行的连边;
跑一次最大匹配即可;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<set>
#include<vector>
#include<queue>
#include<bitset>
#include<ctime>
#include<deque>
#include<stack>
#include<functional>
#include<sstream>
#include<cctype>
//#pragma GCC optimize("O3")
using namespace std;
#define maxn 500005
#define inf 0x3f3f3f3f
#define INF 0x7fffffff
typedef long long ll;
typedef unsigned long long ull;
typedef unsigned int U;
#define ms(x) memset((x),0,sizeof(x))
const long long int mod = 1e9 + 7;
#define Mod 999911659
#define sq(x) (x)*(x)
#define eps 1e-6
const int N = 2500005;
inline int rd() {
int x = 0;
char c = getchar();
bool f = false;
while (!isdigit(c)) {
if (c == '-') f = true;
c = getchar();
}
while (isdigit(c)) {
x = (x << 1) + (x << 3) + (c ^ 48);
c = getchar();
}
return f ? -x : x;
}
ll gcd(ll a, ll b) {
return b == 0 ? a : gcd(b, a%b);
}
int t, n;
int G[700][700];
bool vis[maxn];
int match[maxn];
int dfs(int x) {
for (int i = 1; i <= n; i++) {
if (G[x][i] && !vis[i]) {
vis[i] = 1;
if (!match[i] || dfs(match[i])) {
match[i] = x; return 1;
}
}
}
return 0;
}
int main()
{
//ios::sync_with_stdio(false);
//t = rd();
cin >> t;
while (t--) {
ms(match); ms(G);
//n = rd();
cin >> n;
for (int i = 1; i <= n; i++) {
for (int j = 1; j <= n; j++)scanf("%d", &G[i][j]);
}
int ans = 0;
for (int i = 1; i <= n; i++) {
ms(vis); ans += dfs(i);
}
if (ans == n)cout << "Yes" << endl;
else cout << "No" << endl;
}
return 0;
}