3235: 逆序数字排序

Time Limit: 1 Sec   Memory Limit: 128 MB

Submit: 63  

Solved: 9

[​Submit​​][​Status​​][​Web Board​​]


Description

现在给你一组数字,要求你把每一个数字逆序(如123变为321)之后进行排序,按从小到大的顺序排列;

Input

第一行一个数字T(T<20),表示共有T组测试数据。

下面T行:每组开始有一个数字X(X<20),表示该组有X个数字,后面是该组的X(x<10000)个数字。

Output

每组数据输出一行,输出按从小到大排列好的数字。

Sample Input

2
4 12 23 15 10
3 123 911 119

Sample Output

1 21 32 51
119 321 911

HINT

可按4位数、3位数、2位数、1位数分情况处理


分析:水题,每读入一个数对其进行逆序处理然后存在数组中,直接用C++ sort函数进行排序输出即可。

#include <stdio.h>
#include <algorithm>
using namespace std;
int a[10005];
int fx(int n)
{
int x=0;
while(n)
{
x=x*10+n%10;
n=n/10;
}
return x;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int q;
scanf("%d",&q);
int i;
for(i=0; i<q; i++)
{
scanf("%d",&a[i]);
a[i]=fx(a[i]);
}
sort(a,a+q);
for(i=0; i<q; i++)
printf("%d ",a[i]);
printf("\n");
}
return 0;
}