一、内容
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.
Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar
3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar
0
Sample Output
Case 1: Yes
Case 2: No
二、思路
- spfa 判断正环,若存在正环则输出YES。 初始化为所有点的钱都是1。
- 判断是否有环, 若到达某点的最短路径中的边数>=n 代表存在环。
三、代码
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int N = 35, M = 2e4 + 5;
struct E {
double w;
int v, next;
} e[M];
int n, m, u, v, len, cas, h[N], cnt[N];
bool vis[N];
char s[N][N];
double d[N], w;
void add(int u, int v, double w) {
e[len].v = v;
e[len].w = w;
e[len].next = h[u];
h[u] = len++;
}
int cmp(char p[]) {
for (int i = 1; i <= n; i++) {
if (!strcmp(p, s[i])) return i;
}
}
int spfa() {
int ct = 0;
memset(cnt, 0, sizeof(cnt));
queue<int> q;
for (int i = 1; i <= n; i++) d[i] = 1, vis[i] = true, q.push(i);
while (!q.empty()) {
int u = q.front();
q.pop();
vis[u] = false;
for (int j = h[u]; j; j = e[j].next) {
int v = e[j].v;
double w = d[u] * e[j].w;
if (d[v] < w) {
d[v] = w;
cnt[v] = cnt[u] + 1;
if (ct > 4 * m) return 1;
if (cnt[v] >= n) return 1;
if (!vis[v]) q.push(v), vis[v] = true;
}
}
}
return 0;
}
int main() {
while (scanf("%d", &n), n) {
memset(h, 0, sizeof(h)); len = 1;
for (int i = 1; i <= n; i++) {
scanf("%s", s[i]);
}
scanf("%d", &m);
char us[30], vs[30];
for (int i = 1; i <= m; i++) {
scanf("%s%lf%s", us, &w, vs);
u = cmp(us); v = cmp(vs);
add(u, v, w);
}
printf("Case %d: ", ++cas);
if (spfa()) printf("Yes\n");
else printf("No\n");
}
return 0;
}