7-26 单词长度
你的程序要读入一行文本,其中以空格分隔为若干个单词,以.结束。你要输出每个单词的长度。这里的单词与语言无关,可以包括各种符号,比如it’s算一个单词,长度为4。注意,行中可能出现连续的空格;最后的.不计算在内。
输入格式:
输入在一行中给出一行文本,以 . 结束
提示:用scanf("%c",…);来读入一个字符,直到读到.为止。
输出格式:
在一行中输出这行文本对应的单词的长度,每个长度之间以空格隔开,行末没有最后的空格。
输入样例:
It’s great to see you here.
输出样例:
4 5 2 3 3 4
灵活运动if-else判断特殊条件
3.代码第一次尝试: 开头,结尾0未考虑全面
第二次尝试:格式错误
#include <stdio.h>
int main()
{
int count = 0, flag = 0, i = 0, Length[100] = { 0 }, j = 0;
char Ch;
do {
scanf("%c", &Ch);
if (Ch != ' ')
{
count++;
flag = 0;
}
else
{
if (flag == 0) //空格未被检验
{
Length[i++] = count;
count = 0;
}
flag = 1; //标记空格已经检验了
}
} while (Ch != '.');
Length[i] = count - 1; //最后一个单词
for (j = 0; j < i + 1; j++)
{
if (j == 0 && Length[j] == 0) //考虑开头0
continue;
if (j == i)
{
if (Length[j] == 0) //考虑结尾0
continue;
else
printf("%d", Length[j]);
}
else
printf("%d ", Length[j]);
}
return 0;
}
错误的例子:最终末尾打印了空格
正确解法:考虑开头,结尾,倒数第二位
#include <stdio.h>
int main()
{
int count = 0, flag = 0, i = 0, Length[100] = { 0 }, j = 0;
char Ch;
do {
scanf("%c", &Ch);
if (Ch != ' ')
{
count++;
flag = 0;
}
else
{
if (flag == 0) //空格未被检验
{
Length[i++] = count;
count = 0;
}
flag = 1; //标记空格已经检验了
}
} while (Ch != '.');
Length[i] = count - 1; //最后一个单词
for (j = 0; j < i + 1; j++)
{
if (j == 0 && Length[j] == 0) //考虑开头0
continue;
if (j == i && Length[j] == 0) //结尾0
continue;
else if (j == i||(j==i-1&&Length[j+1]==0)) //当最后一位不为0 或者 结尾为0时倒数第二位的打印
printf("%d", Length[j]);
else
printf("%d ", Length[j]);
}
return 0;
}
4.总结
现阶段仍然欠缺模块化的思路,程序较为冗杂,待过些时日,沉淀沉淀,会优化代码的
5.更新日志2022.3.14 整理上传