问题 : 看电视
时间限制: 1 Sec 内存限制: 32 MB题目描述
现在他把他喜欢的电视节目的转播时间表给你,你能帮他合理安排吗?
输入
接下来n行,每行输入两个整数si和ei(1<=i<=n),表示第i个节目的开始和结束时间,为了简化问题,每个时间都用一个正整数表示。
当n=0时,输入结束。
输出
样例输入
12
1 3
3 4
0 7
3 8
15 19
15 20
10 15
8 18
6 12
5 10
4 14
2 9
0
样例输出
5
解题思路
这道题是一道简单的贪心问题,其实就是让你找互不相交的最大区间数。#include <stdio.h>
#include <algorithm>
using namespace std;
struct node{
int left, right;
} arr[102];
int cmp(node x, node y)
{
return x.right < y.right;
}
int main()
{
int t, n, x, y, r, temp, count;
while (scanf("%d", &n), n)
{
for (int i = 0; i < n; i++)
scanf("%d%d", &arr[i].left, &arr[i].right);
sort(arr, arr + n, cmp);
temp = arr[0].right;
count = 1;
for (int i = 1; i < n; i++)
{
if (temp <= arr[i].left)
{
temp = arr[i].right;
count++;
}
}
printf("%d\n", count);
}
return 0;
}