Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 104215 | Accepted: 45370 |
Description
After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)
Input
Output
Sample Input
2
1.0 1.0
25.0 0.0
Sample Output
Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.
Hint
2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.
3.All locations are given in miles.
Source
问题链接:UVALive2363 POJ1005 HDU1065 ZOJ1049 I Think I Need a Houseboat。
问题简述:(略)
问题分析:
计算半径的公式为:r^2 = x^2 + y^2
计算半圆面积公式:area = πr^2/2
侵袭年数:year = (int)ceil(area / 50.0)
程序说明:
如果PI=3.1415926,那么UVALive2363会出现WA,精度问题;
如果PI=3.1415926535,那么HDU1065中会出现WA。
简直不可理喻啊!!!
AC通过的C++语言程序如下:
/* UVALive2363 POJ1005 HDU1065 ZOJ1049 I Think I Need a Houseboat */
#include <iostream>
#include <stdio.h>
using namespace std;
const double PI = 3.1415926535;
int main()
{
int t;
double x, y;
cin >> t;
for(int i=1; i<=t; i++) {
cin >> x >> y;
printf("Property %d: This property will begin eroding in year %d.\n", i, int((x*x + y*y) * PI / 100 + 1));
}
printf("END OF OUTPUT.\n");
return 0;
}