Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 4849 | Accepted: 2293 |
Description
A closed polygon is called convex if the line segment joining any two points of the polygon lies in the polygon. Figure 1 shows a closed polygon which is convex and one which is not convex. (Informally, a closed polygon is convex if its border doesn't have any "dents".)
The subject of this problem is a closed convex polygon in the coordinate plane, one of whose vertices is the origin (x = 0, y = 0). Figure 2 shows an example. Such a polygon will have two properties significant for this problem.
The first property is that the vertices of the polygon will be confined to three or fewer of the four quadrants of the coordinate plane. In the example shown in Figure 2, none of the vertices are in the second quadrant (where x < 0, y > 0).
To describe the second property, suppose you "take a trip" around the polygon: start at (0, 0), visit all other vertices exactly once, and arrive at (0, 0). As you visit each vertex (other than (0, 0)), draw the diagonal that connects the current vertex with (0, 0), and calculate the slope of this diagonal. Then, within each quadrant, the slopes of these diagonals will form a decreasing or increasing sequence of numbers, i.e., they will be sorted. Figure 3 illustrates this point.
Input
Output
Sample Input
0 0 70 -50 60 30 -30 -50 80 20 50 -60 90 -20 -30 -40 -10 -60 90 10
Sample Output
(0,0) (-30,-40) (-30,-50) (-10,-60) (50,-60) (70,-50) (90,-20) (90,10) (80,20) (60,30)
Source
#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAXN 55
struct Node
{
int x,y;
};
Node p[MAXN];
int cross(Node p0,Node p1,Node p2)
{
return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}
bool cmp(Node p1,Node p2)
{
int tmp=cross(p[0],p1,p2);
if(tmp>0) return true;
else return false;
}
int main()
{
// freopen("test.in","r",stdin);
//freopen("test.out","w",stdout);
int n=0;
while(scanf("%d%d",&p[n].x,&p[n].y)!=EOF)n++;
sort(p+1,p+n,cmp);
for(int i=0;i<n;i++)
printf("(%d,%d)\n",p[i].x,p[i].y);
// system("pause");
return 0;
}