题目描述:
给你一个年份和月份,求该月有多少天 。
输入:
一个年份(正整数),一个月份(1-12),中间有一个空格隔开
输出:
该月的天数,单独占一行。
样例输入:
2012 2
样例输出:
29
解题思路:
闰年和平年的1,3,5,7,8,10,12月均为31天,4,6,9,11月均为30天,所以这两种就可以共同处理,看成同一种情况,所以只需要考虑2月的天数就可以了,闰年2月29天,平年2月28天,判断是否为闰年就是 (year%400==0||(year%4==0&&year%100!=0)) 。
程序代码:
import java.util.*;
public class Main
{
public static void main(String[] args)
{
Scanner input=new Scanner(System.in);
int year=input.nextInt();
int month=input.nextInt();
if(year%400==0||(year%4==0&&year%100!=0))
{
if(month==2)
System.out.println("29");
}
else
{
if(month==2)
System.out.println("28");
}
if(month==1||month==3||month==5||month==7||month==8||month==10||month==12)
System.out.println("31");
if(month==4||month==6||month==9||month==11)
System.out.println("30");
}
}