Summary



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description


N∗(N−1)2


 


Input


a1,a2,…,an separated by exact one space. Process to the end of file. [Technical Specification] 2 ≤n≤100 -1000000000 ≤ai≤1000000000


 


Output


For each case, output the final sum.


 


Sample Input


4 1 2 3 4 2 5 5


 


Sample Output


Hint

Firstly small W takes any pair of 1 2 3 4 and add them, he will get 3 4 5 5 6 7. Then he deletes the repeated numbers, he will get 3 4 5 6 7, Finally he gets the sum=3+4+5+6+7=25.

/*题解:


很简单的题,但是需要注意测试数据的范围,用__int64输出结果


*/


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
__int64 a[110],b[10000],sum;
int main()
{
int i,j,k,n;
while(scanf("%d",&n)!=EOF)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
for(i=0; i<n; i++)
scanf("%I64d",&a[i]);
for(i=0,k=0; i<n-1; i++)
{
for(j=i+1; j<n; j++)
{
b[k++] = a[i]+a[j];
}
}
sort(b,b+k);
for(i=1,sum=b[0]; i<k; i++)
{
if(b[i]!=b[i-1])
sum+=b[i];
else
continue;
}
printf("%I64d\n",sum);
}
}