Painter


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 745    Accepted Submission(s): 345



Problem Description


Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.


 



Input


The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.


 



Output


Output an integer as described in the problem description.


 



Sample Input


2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR


 



Sample Output


3 6


 



Source


2015 Multi-University Training Contest 3


 



Recommend


wange2014   |   We have carefully selected several similar problems for you:   5325  5324  5322  5321  5320 






     题意:在一个n*m的长方形画板上进行染色,其中红色只能'\'画,蓝的只能'/'画,如果一个格子上既有红的又有蓝的,那么这个格子就变成了绿色,现在给你一个状态(就是经过x步操作画板上能到达的颜色状态),求最小的步数x


     思路:这个题的最坑之处在于没有给出m,如果当成正方形算的话,一辈子都交不上,英语弱渣的悲哀.......








#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

using namespace std;

char pp[91][91];
int v[91][91];
int n,m;

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int ans = 0;
        int k;
        memset(v,0,sizeof(v));
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%s",pp[i]);
            k = strlen(pp[i]);

        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<k;j++)
            {
                if((pp[i][j] == 'R' || pp[i][j] == 'G')&& v[i][j] == 0)
                {
                    int ii = i,jj = j;
                    while((pp[ii][jj] == 'R' || pp[ii][jj] == 'G') && v[ii][jj] == 0)
                    {
                        v[ii][jj]++;
                        //printf("v[%d][%d] = %d\n",ii,jj,v[ii][jj]);
                        ii = ii + 1;
                        jj = jj + 1;
                        if(ii>=n || jj>=k)
                        {
                            break;
                        }
                    }
                    ans++;
                }
            }
        }
        //printf("ans =      %d\n",ans);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<k;j++)
            {
                if((pp[i][j] == 'B'&&v[i][j] == 0) || (pp[i][j] == 'G' && v[i][j] == 1))
                {
                    int x = i;
                    int y = j;
                    //printf("x = %d    y = %d\n",x,y);
                    while((pp[x][y] == 'B' && v[x][y] == 0) || (pp[x][y] == 'G' && v[x][y] == 1))
                    {
                        v[x][y]++;
                        //printf("v[%d][%d] = %d\n",x,y,v[x][y]);
                        x = x + 1;
                        y = y - 1;
                        if(x>=n || y<0)
                        {
                            break;
                        }
                    }
                    ans++;
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}