Problem F
Solve It
Input: standard input
Output: standard output
Time Limit: 1 second
Memory Limit: 32 MB
Solve the equation:
p*e-x+ q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
where 0 <= x <= 1.
Input
Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: p, q, r, s, t and u (where 0 <= p,r<= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.
Output
For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.
Sample Input
0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1
Sample Output
0.7071
No solution
0.7554
题意:找到一个数X满足 p*e-x+ q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
代码:
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
using namespace std;
double p,q,r,s,t,u;
double findx(double x)
{
return p*exp(-x)+q*sin(x)+r*cos(x)+s*tan(x)+t*x*x+u;
}
int main()
{
while(scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u)!=EOF)
{
if(findx(0)<0 || findx(1)>0)
{
printf("No solution\n");
}
else
{
double x1 = 0;
double x2 = 1;
while(fabs(x1-x2)>=1e-10)
{
double x = (x1+x2)/2;
if(findx(x)>0)
{
x1 = x;
}
else
{
x2 = x;
}
}
printf("%.4lf\n",x1);
}
}
return 0;
}
Mustaq Ahmed