The Water Problem
Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 425 Accepted Submission(s): 339
Problem Description
a1,a2,a3,...,anrepresenting the size of the water source. Given a set of queries each containing 2 integers l and r, please find out the biggest water source between al and ar.
Input
T(T≤10) indicating the number of test cases. For each test case, there is a number n(0≤n≤1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,...,an, and each integer is in {1,...,106}. On the next line, there is a number q(0≤q≤1000) representing the number of queries. After that, there will be q lines with two integers l and r(1≤l≤r≤n)
Output
For each query, output an integer representing the size of the biggest water source.
Sample Input
3
1
100
1
1 1
5
1 2 3 4 5
5
1 2
1 3
2 4
3 4
3 5
3
1 999999 1
4
1 1
1 2
2 3
3 3
Sample Output
100 2 3 4 4 5 1 999999 999999 1
Source
2015 ACM/ICPC Asia Regional Changchun Online
#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
using namespace std;
const int N = 20010;
int maxx[N][30];
int minn[N][30];
int n,m;
void play(){
int l = floor(log10(double(n))/log10(double(2)));
for(int j=1;j<=l;j++){
for(int i=1;i<=n+1-(1<<j);i++){
maxx[i][j] = max(maxx[i][j-1],maxx[i+(1<<(j-1))][j-1]);
}
}
}
int main(){
int T;
scanf("%d",&T);
while(T--){
int x,y;
scanf("%d",&n);
for(int i=1;i<=n;i++){
scanf("%d",&x);
maxx[i][0] = x;
minn[i][0] = x;
}
play();
scanf("%d",&m);
while(m--){
scanf("%d%d",&x,&y);
int pp = floor(log10(double(y-x+1))/log10(double(2)));
printf("%d\n",max(maxx[x][pp],maxx[y-(1<<pp)+1][pp]));
}
}
return 0;
}