Currency Exchange

Time Limit: 1000MS

 

Memory Limit: 30000K

Total Submissions: 42517

 

Accepted: 16354

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103. 
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102. 
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104. 

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input


3 2 1 20.0 1 2 1.00 1.00 1.00 1.00 2 3 1.10 1.00 1.10 1.00


Sample Output


YES


题意:n个货币,m个货币交换站,每个货币交换站给出两种可以交换的货币和汇率,及手续费。给出初始的货币类型,及数量。问能否经过一系列货币交换把自己的钱增值。(os:啧啧啧秀儿)

方法:可以用Spfa或者Bellman-Ford判断构造的图中是否有正环。因为如果存在正环,则一定能无限走这个正环然后回到起点钱一定会增值。

(正权回路:在这一回路上,顶点的权值能不断增加即能不断进行松弛)

Bellman-Ford

//找正环,就最大路径
#include <iostream>
#include <cstring>
#include <string>
#include <cmath>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <stack>
#define Max 111
using namespace std;
int n, m, s, cnt;
double v;
double dis[Max];
struct Node{
int a, b;
double r;//rate
double c;//commission
}edge[Max<<1];
void add_edge(int u, int v, double ruv, double cuv, double rvu, double cvu) {
edge[cnt].a = u; edge[cnt].b = v;
edge[cnt].r = ruv; edge[cnt++].c = cuv;

edge[cnt].a = v; edge[cnt].b = u;
edge[cnt].r = rvu; edge[cnt++].c = cvu;
}
bool bellman_Ford() {
memset (dis, 0, sizeof(dis));
dis[s] = v;
bool flag;
for (int i = 1; i <= n-1; i++){
flag = false;
for (int j = 0; j < cnt; j++) {
if (dis[edge[j].b] < (dis[edge[j].a] - edge[j].c)*edge[j].r) {
dis[edge[j].b] = (dis[edge[j].a] - edge[j].c)*edge[j].r;
flag = true;
}
}
if(!flag) break;
}
//search positive circle
//松弛完还能在松弛就代表有正环
for (int i = 0; i < cnt; i++){
if(dis[edge[i].b] < (dis[edge[i].a] - edge[i].c)*edge[i].r) {
return true;
}
}
return false;
}
int main() {
while (cin >> n >> m >> s >> v) {
cnt = 0;//总边数
int u, v;
double Ruv, Cuv, Rvu, Cvu;
for (int i = 0; i < m; i++) {
cin >> u >> v >> Ruv >> Cuv >> Rvu >> Cvu;
add_edge(u, v, Ruv, Cuv, Rvu, Cvu);
}
bool ans = bellman_Ford();
if (ans) cout << "YES" << endl;
else cout << "NO" << endl;
}
return 0;
}

Spfa

//找正环,就最大路径
#include <iostream>
#include <cstring>
#include <string>
#include <cmath>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <stack>
#include <vector>
#define Max 111
using namespace std;
struct Node {
int v;
double r, c;
Node(int _v = 0, double _r = 0, double _c = 0):v(_v),r(_r),c(_c){}
};
vector<Node> edge[Max];
bool vis[Max];
double dis[Max];
int n, m, s;
double V;
void add_edge(int u, int v, double r, double c){
edge[u].push_back(Node(v,r,c));
}
bool Spfa() {
memset(vis, false, sizeof(vis));
for(int i = 1; i <= n; i++){
dis[i] = 0;
}
queue <int> q;
while(!q.empty()) q.pop();
q.push(s);
dis[s] = V;vis[s] = true;
while(!q.empty()){
int u = q.front();
q.pop();
vis[u] = false;
for(int i = 0; i < edge[u].size(); i++) {
int v = edge[u][i].v;
double c = edge[u][i].c;
double r = edge[u][i].r;
if(dis[v] < (dis[u] - c)*r){
dis[v] = (dis[u] - c)*r;
if(!vis[v]) {
q.push(v);
vis[v] = true;
}
}
if(dis[s] > V)
return true;
}
}
return false;
}
int main() {
ios::sync_with_stdio(false);
while(cin >> n >> m >> s >> V) {
for(int i = 1; i <= n; i++) edge[i].clear();
for (int i = 0; i < m; i++){
int u, v;
double Ruv, Cuv, Rvu, Cvu;
cin >> u >> v >> Ruv >> Cuv >> Rvu >> Cvu;
add_edge(u, v, Ruv, Cuv);
add_edge(v, u, Rvu, Cvu);
}
bool ans = Spfa();
if(ans) cout<< "YES" << endl;
else cout << "NO" <<endl;
}
return 0;
}
/*
3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00
*/