1134 Vertex Cover (25分)

vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

Nv v[1] v[2]⋯v[Nv]

where Nv is the number of vertices in the set, and v[i]'s are the indices of the vertices.

Output Specification:

For each query, print in a line ​​Yes​​​ if the set is a vertex cover, or ​​No​​ if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2

Sample Output:

No
Yes
Yes
No
No

 看给出的顶点是否覆盖了所有的边,是的话输出Yes ,反之 No

STL是真的好用

#include <bits/stdc++.h>
#define Max 10024
using namespace std;
vector<int> vec[Max]; //与 i 点关联的 边
int vis[Max]; //边数
int n, m, q, nv;
int u, v;
int main(){
cin >> n >> m;
for(int i = 0; i < m; i++){
cin >> u >> v;
vec[u].push_back(i);
vec[v].push_back(i);
}
cin >> q;
while(q --) {
memset(vis, 0, sizeof(vis));
cin >> nv;
for(int i = 0; i < nv; i++){
cin >> u;
for(int j = 0; j < vec[u].size(); j++){
vis[vec[u][j]] = 1;
}
}
int flag = 0;
for(int i = 0; i < m; i++){
if(vis[i] != 1) {
flag = 1;
// cout << "No" << endl;
break;
}
}
if(flag) cout << "No" << endl;
else cout << "Yes" << endl;
}
return 0;
}
//把每个顶点关联的边存储起来 边的编号 从 1 开始